hdu 1829-BFS二分图染色-输出真坑!!!!!!!!!!!!!!

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18137    Accepted Submission(s): 5782


Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
 
 
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
 
 
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 

Source

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<vector>

using namespace std;

vector<int> map[3000];
int color[3000],n,row,flag,from,to,vis[3000];
 
void init()
{
	flag = 0; 
	memset(color,-1,sizeof(color));
	memset(vis,0,sizeof(vis));//BFS少不了标记
	for(int i = 1; i <= n; i++)
		map[i].clear();	
	while(row--)//构建图 
	{
		scanf("%d%d",&from,&to);
		map[from].push_back(to);//注意无向图
		map[to].push_back(from);
	}
}

bool BFS(int s)
{
	color[s] = 1;
	queue<int> q;
	q.push(s);
	while(!q.empty())
	{
		int temp = q.front();
		q.pop();
		if(!vis[temp])
		{
			for(int  i = 0; i < map[temp].size(); i++)
			{ 
				q.push(map[temp][i]);
				if(color[ map[temp][i] ] == -1)
					color[ map[temp][i] ] = color[temp] == 1?0:1;
				else 
				{
					if(color[ map[temp][i] ] == color[temp])
						return false;
					else 
						continue;
				}	
				
			}
			vis[temp] = 1;
		} 
	}
	return true;
}

int main()
{
	int t;
	scanf("%d",&t);
	for(int count = 1; count <= t; count++)
	{
		scanf("%d%d",&n,&row);//n为虫子的数目,row为接下来有row对虫子相互喜欢 
		init();
		printf("Scenario #%d:\n",count);
		for(int i = 1; i <= n; i++)//开始,每一个虫子都属于自己的集合 
		{
			if(!vis[i])
			{
				if(!BFS(i))
				{
					flag = 1;
					break;
				}
			}
		}
		if(!flag)
			printf("No suspicious bugs found!\n\n");//注意两个换行
		else 
			printf("Suspicious bugs found!\n\n");//我想知道为什么我复制粘贴粘贴过来的时候,S从大写变成了小写,害我找了两天的bug,mmp
	} 
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值