钱币兑换问题(1284)

3 篇文章 0 订阅
在一个国家仅有1分,2分,3分硬币,将钱N兑换成硬币有很多种兑法。请你编程序计算出共有多少种兑法。
 

Input
每行只有一个正整数N,N小于32768。
 

Output
对应每个输入,输出兑换方法数。
 

Sample Input
  
  
2934 12553
 

Sample Output
  
  
718831

13137761

一:数学

#include <stdio.h> 
#include <string.h>  
#include <math.h>  
#include <stdlib.h>  
#include <ctype.h> 	
int main()  
{	long long int san,er,yi;
	long long int sum,count;
	int N;
	
	while(scanf("%d",&N)!=EOF)
	{
		count=0;
		for(san=0;san*3<=N;san++)    //三块的个数
		{
			sum=N-san*3;
			
			if(sum%2==0)    //二块的个数,剩下的只能是一块的个数
			count+=sum/2;
			else
			count+=(sum-1)/2;			
		}
		count+=(long long int)((double)(N)/3)+1;
		printf("%I64d\n",count);
	} 
	      
    return 0;  
}

二:dp
#include <stdio.h> 
#include <string.h>  
#include <math.h>  
#include <stdlib.h>  
#include <ctype.h>  
int main()  
{  
	int dp[32769];
    int i,j,n;
    
	memset(dp,0,sizeof(dp));    
	dp[0]=1;
    for(i=1;i<=3;i++)
    {
  	 	for(j=i;j<=32768;j++)
        {
        	dp[j]+=dp[j-i];
        }
    }   
    while(scanf("%d",&n)!=EOF)
	{
	    printf("%d\n",dp[n]);
    }
 
    return 0;  
} 



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值