PAT 1128 N Queens Puzzle

原题链接:1128 N Queens Puzzle (20分)
关键词:模拟
重新整理时间:2021.6.3

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1​​ ,Q2​​ ,⋯,QN​​ ), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.

在这里插入图片描述
Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format “N Q1 Q2… Qn”, where 4≤N≤1000 and it is guaranteed that 1≤Q​i≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or 4 if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

题目大意: N-皇后问题是在n*n的棋盘上摆上n个皇后,要求任意两个皇后不在同一行、同一列、同一斜线上。

本题给出了几个可能,问你是否是N-皇后问题的解。

分析: 题目已经保证每列都只有一个皇后,因此只要判断行和斜线是否满足。

用vector v存储每个皇后,v[i]是他的行数,i是他的列数。
对于第i个皇后,需要检查在它之前的所有皇后:

  1. 在同一行:v[i] == v[j]
  2. 在同一斜线上:abs(v[i]-v[j]) == abs(i-j)

条件达成说明不满足需要,flag设为false


代码实现:

//pat 1128
#include <iostream>
#include <vector>
using namespace std;

int k;

int main(){
    cin >> k;
    while(k--){ //k个用例
        int n;
        cin >> n;
        bool flag = true;
        vector<int> v(n+1);
        
        for(int i = 1; i <= n; i ++ ){
            cin >> v[i];    //v[i]是行数 i是列数
            for(int j = 1; j < i; j ++ ){
                if(v[i] == v[j] || abs(v[i] - v[j]) == abs(i - j)){
                    flag = false;
                    break;
                }
            }
        }
        if(flag) cout << "YES" << endl;
        else cout << "NO" << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值