PAT 1110 Complete Binary Tree

原题链接:1110 Complete Binary Tree (25分)
关键词:完全二叉树

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

题目大意: 给出结点的左右孩子,让你判断这棵树是不是完全二叉树

分析: 看样例的时候看了好几遍还是不懂- -,因为他给的结点编号并不是按照层序遍历给出的,也就是说根结点不固定是0。

  • 输入的时候要用string不能用char,因为编号可能是两位数的
  • 递归出最大的下标值,满足完全二叉树的话最大的下标值 == 最大的节点数;不完全二叉树一定有位置是空,会往后挤: 最大的下标值 > 最大的节点数

代码:

//pat 1110 
#include <bits/stdc++.h>
using namespace std;

struct node{
	int l, r;
}a[25];

bool c[25] = {0};	//是否有父结点 
int ans = 0;    //最后一个结点的编号
int mx = -1;	//最大的下标值

void dfs(int root, int index){
	if(mx < index){
		mx = index;
		ans = root;
	}
	if(a[root].l != -1) dfs(a[root].l, index * 2);
	if(a[root].r != -1) dfs(a[root].r, index * 2 + 1);
} 
	
int main(){
	int n, root = 0;
	cin >> n;

	for(int i = 0; i < n; i ++ ){
		string s1, s2;
		cin >> s1 >> s2;
		if(s1 == "-") a[i].l = -1;
		else {
			a[i].l = stoi(s1);
			c[a[i].l] = 1; 
		} 
		if(s2 == "-") a[i].r = -1;
		else {
			a[i].r = stoi(s2);
			c[a[i].r] = 1;
		}
	}
	while(c[root]) root++;
	dfs(root, 1);
	
    //printf("%d %d", mx, ans);
	if(mx == n) printf("YES %d", ans);
	else printf("NO %d", root);
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
To convert the given array to a complete BST, we need to perform the following steps: 1. Sort the array in ascending order 2. Construct a complete binary tree using the sorted array 3. Perform inorder traversal of the binary tree and store the elements in the original array in the same order as the traversal Here's the implementation of the to_bst(lst) function in Python: ```python def to_bst(lst): # Sort the input list lst.sort() # Construct a complete binary tree using the sorted list n = len(lst) if n == 0: return lst root = lst[n // 2] left_subtree = to_bst(lst[:n // 2]) right_subtree = to_bst(lst[n // 2 + 1:]) binary_tree = [root] + left_subtree + right_subtree # Perform inorder traversal of the binary tree and store the elements in the original array inorder_traversal(binary_tree, lst, 0) return lst def inorder_traversal(binary_tree, lst, i): # Perform inorder traversal of the binary tree and store the elements in the original array n = len(binary_tree) if i >= n: return inorder_traversal(binary_tree, lst, 2 * i + 1) lst[i] = binary_tree[i] inorder_traversal(binary_tree, lst, 2 * i + 2) ``` The to_bst(lst) function takes in the input list and returns the same list after converting it to a complete BST. The function first sorts the input list in ascending order. It then constructs a complete binary tree using the sorted list by recursively dividing the list into two halves and setting the middle element as the root of the binary tree. Finally, the function performs an inorder traversal of the binary tree and stores the elements in the original list in the same order as the traversal.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值