PAT 1070 Mooncake (25 分)

原题链接:1070 Mooncake (25 分)
关键词:贪心

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

题目大意:

给定N种月饼、月饼的总需求量D以及各种月饼的供应量和总价格,问怎么样销售带来的利润最大。

分析:

首先根据存量和总价求出单位价值,根据单位价值对所有月饼排序。
贪心的思想,月饼单位价值高的优先级高,优先级最高的月饼库存不够用就用第二高的,以此类推来达到最终金额最大。

注意:

总价给出是double型的, 因此在定义数量和均价的时候也要用double,否则答案会出错


代码实现:

#include <iostream>
#include <algorithm>
using namespace std;

int n;	//n种类数
double d;   //d需求量
struct mooncake{
    double num; //数量
    double val_sum; //总价
    double price; //均价
    
}cakes[1010];

bool cmp(mooncake a, mooncake b){
    return a.price > b.price;	//按均价从高到低排序
}

int main(){
    cin >> n >> d;
    
    for(int i = 0; i < n; i ++ ){
        cin >> cakes[i].num;
    }
    for(int i = 0; i < n; i ++ ){
        cin >> cakes[i].val_sum;
        cakes[i].price = cakes[i].val_sum / cakes[i].num;
    }
    
    sort(cakes, cakes + n, cmp);
    
    double ans = 0;
    for(int i = 0; i < n; i ++ ){
        if(d >= cakes[i].num){  //需求量大于当前存量
            ans += cakes[i].val_sum;
            d -= cakes[i].num;
        }
        else{   //需求量小于当前存量
            ans += cakes[i].price * d;
            break;
        }
    }
    printf("%.2f", ans);
    
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
import java.io.BufferedReader; import java.io.IOException; import java.io.InputStreamReader; import java.util.ArrayList; import java.util.Arrays; import java.util.Collection; import java.util.Collections; import java.util.LinkedList; import java.util.List; import java.util.Scanner; public class Main{ public static void main(String[] args) throws IOException { BufferedReader in=new BufferedReader(new InputStreamReader(System.in)); int n; double need; double sum=0; String s[]=in.readLine().split(" "); n=Integer.parseInt(s[0]); need=Double.parseDouble(s[1]); String amount[]=in.readLine().split(" "); String price[]=in.readLine().split(" "); ArrayList<Mooncake> cakes=new ArrayList<Mooncake>(); for(int i=0;i<n;i++){ Mooncake cake=new Mooncake(); cake.setAmount(Double.parseDouble(amount[i])); cake.setSales(Double.parseDouble(price[i])); cake.setValues(Double.parseDouble(price[i])/Double.parseDouble(amount[i])); cakes.add(cake); } Collections.sort(cakes); for(Mooncake c: cakes){ if(need>=c.amount){ need=need-c.amount; sum+=c.amount*c.values; } else{ sum+=need*c.values; need=0; } if(need==0){ break; } } System.out.printf("%.2f",sum); } static class Mooncake implements Comparable<Mooncake>{ double amount; double sales; double values; public double getAmount() { return amount; } public void setAmount(double amount) { this.amount = amount; } public double getSales() { return sales; } public void setSales(double sales) { this.sales = sales; } public double getValues() { return values; } public void setValues(double values) { this.values = values; } @Override public int compareTo(Mooncake arg0) { // TODO Auto-generated method stub return this.values>arg0.values?-1:1; } } }转c++
最新发布
05-23
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值