HDOJ1088

Write a simple HTML Browser

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7646    Accepted Submission(s): 2141


Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed. 
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do? 
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags) <br> which is a linebreak and <hr> which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.
 

Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines. 
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>.
 

Output
You should display the the resulting text using this rules: 
  . If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line. 
  . If you read a <br> in the input, start a new line. 
  . If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again). 
The last line is ended by a newline character.
 

Sample Input
  
  
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. <br> Zwei <br> <br> produzieren zwei Newlines. Es gibt auch noch das tag <hr> was einen Trenner darstellt. Zwei <hr> <hr> produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
 

Sample Output
  
  
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. Zwei produzieren zwei Newlines. Es gibt auch noch das tag -------------------------------------------------------------------------------- was einen Trenner darstellt. Zwei -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
 

Source

【题意】就是让你对一段文字做三种处理:
  一、“<br>"指令,换行;
        二、”<hr>"指令,如果已经新的一行的开头则直接输出80个‘-’,否则,换行再输出80个‘-’;
三、将若干连续的空格与换行(可以同时都有)作为一个space(空格)输出;
最后要输出一个换行;
        注意输出时每行的字符不能超过80个,单词必须要在同一行输出,标点符号当作是单词的一部分(如果中间没有空格或换行的话);换行也可以视作分离两个单词,所以只需其中的一个就够了。

      这题格式很重要。一开始我用字符读入,一直PE;后来换了字符串读入就过了(c++);
    
#include<cstdio>
#include<cstring>
char a[81];
int main()
{
      int p=0;
      while(scanf("%s",a+1)!=EOF)
      {
            int len=strlen(a+1);            
            if(a[1]=='<')
            {
                  if(a[2]=='b')printf("\n");
                   else{
                          if(p)printf("\n");
                          for(int i=1;i<=80;i++)printf("-");
                          printf("\n");
                        }
                 p=0;
            }else if(p==0)
          {
                                     for(int i=1;i<=len;i++)printf("%c",a[i]);
                                     p=len;
          }else    if(p+len>=80)
                      {
                                     printf("\n");
                                     for(int i=1;i<=len;i++)printf("%c",a[i]);
                                     p=len;
                    }else
                    if(p+len<80){
                            printf(" ");
                             for(int i=1;i<=len;i++)printf("%c",a[i]);
                             p+=len+1;
                    }
    }
    printf("\n");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值