A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input
Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.
Sample Input
2 1
01 1 02
Sample Output
0 1
题意:给出一颗树,求各层的叶结点数目。
思路:将树看成图(考树的话一般是二叉树),来一遍DFS,将每层的叶子结点存入num[ ]数组中。
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> tree[100];
int maxdeep = -1;
int n,m;
int num[100]={0};
void DFS(int node, int deep)
{
if(tree[node].size() == 0)
{
num[deep]++;
maxdeep = max(maxdeep,deep);
return ;
}
for(int i=0;i<tree[node].size();i++)
{
DFS(tree[node][i], deep+1);
}
}
int main()
{
int r,k,s;
cin >> n >> m;
for(int i=0;i<m;i++)
{
cin >> r >> k;
for(int j=0;j<k;j++)
{
cin >> s;
tree[r].push_back(s);
}
}
DFS(1,0);
for(int i=0;i<maxdeep;i++)
{
cout << num[i] << " ";
}
cout << num[maxdeep];
return 0;
}