1016

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word “on-line” or “off-line”.

For each test case, all dates will be within a single month. Each “on-line” record is paired with the chronologically next record for the same customer provided it is an “off-line” record. Any “on-line” records that are not paired with an “off-line” record are ignored, as are “off-line” records not paired with an “on-line” record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.
Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 12.10Totalamount: 12.10
CYLL 01
01:06:01 01:08:03 122 24.4028:15:4128:16:0524 3.85
Total amount: 28.25aaa0102:00:0104:23:594318 638.80
Total amount: $638.80

题意:给出每天每个时间段的收费,和每条通话记录,on-line开始通话,off-line结束通话,求话费账单。
思路:全程参考柳婼….
先按名字排序,再按时间排序,连续两个相同名字且一个on-line,一个off-line为有效账单。
tip:遇到时间加减用int(输入时就用)而不是string,费用加减可以设置一个公共起点0(如代码中的每月1号0点0分)各自先算费用在相减,这样相减就比较好减!!

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>

using namespace std;

struct node
{
    string name;
    int month,date,hour,min,sta,time;
};

bool cmp(node a, node b)
{
    return (a.name != b.name) ? (a.name < b.name) : (a.time < b.time);
}

double billfrom0hour(node a, int *cost)
{
    double bill =  a.date *cost[24]*60 + cost[a.hour] * a.min;;
    for(int i=0;i<a.hour;i++)
    {
        bill += cost[i]*60;
    }
    return bill/100.0;
}


int main()
{
    int cost[25] = {0};
    for(int i=0;i<24;i++)
    {
        scanf("%d", &cost[i]);
        cost[24] += cost[i];
    }
    int n;
    scanf("%d", &n);
    vector<node> record(n);
    for(int i=0;i<n;i++)
    {
        cin >> record[i].name;
        string s;
        scanf("%d:%d:%d:%d", &record[i].month, &record[i].date, &record[i].hour, &record[i].min);
        cin >> s;
        record[i].sta = (s == "on-line") ? 1 : 0;
        record[i].time = record[i].date*24*60 + record[i].hour*60 + record[i].min;
    }
    sort(record.begin(), record.end(), cmp);
    map<string, vector<node> > custom;
    for(int i=1;i<n;i++)
    {
        if(record[i].name == record[i-1].name && record[i-1].sta == 1 && record[i].sta == 0)
        {
            custom[record[i].name].push_back(record[i-1]);
            custom[record[i].name].push_back(record[i]);
        }
    }
    for(auto it : custom)
    {
        vector<node> temp = it.second;
        cout << it.first;
        printf(" %02d\n", temp[0].month);
        double total = 0.0;
        for(int i=1;i<temp.size();i += 2)
        {
            double bill = billfrom0hour(temp[i], cost) - billfrom0hour(temp[i-1], cost);
            printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n", temp[i-1].date, temp[i-1].hour, temp[i-1].min, temp[i].date, temp[i].hour, temp[i].min, temp[i].time-temp[i-1].time, bill);
            total += bill;
        }
        printf("Total amount: $%.2f\n", total);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值