1017

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.
Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

题意:给出银行窗口数,每个客户来的时间和服务的时间,求每个人的平均等待时间
思路:将客户按来的时间排序,window数组存放每个窗口空闲那刻的时间。
tip:遇到时间化成int(秒),并设置一个公共起始0时间

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

struct cust
{
    int arrt;
    int prct;
};

bool cmp(cust a, cust b)
{
    return a.arrt < b.arrt;
}

int main()
{
    int N,K;
    cin >> N;
    cin >> K;
    vector<cust> cus(N);
    for(int i=0;i<N;i++)
    {
        int hour,min,sec,prc;
        scanf("%d:%d:%d %d", &hour, &min, &sec, &prc);
        cus[i].arrt = hour*60*60+min*60+sec;
        cus[i].prct = prc*60;
    }
    sort(cus.begin(), cus.end(), cmp);
    int window[K] = {0};
    for(int i=0;i<K;i++)
    {
        window[i] = 28800;
    }
    double total=0.0;
    int npeople = 0;
    for(int i=0;i<N;i++)
    {
        if(cus[i].arrt <= 61200)
        {
            int t = window[0];
            int k = 0;
            for(int j=1;j<K;j++)
            {
                if(window[j] < t)
                {
                    t = window[j];
                    k = j;
                }
            }
            if(window[k] > cus[i].arrt)
            {
                total += window[k] - cus[i].arrt;
                if(cus[i].prct <= 3600)
                    window[k] += cus[i].prct;
                else
                    window[k] += 3600;
            }
            else
            {
                if(cus[i].prct <= 3600)
                    window[k] += cus[i].arrt -window[k] + cus[i].prct;
                else
                    window[k] += cus[i].arrt -window[k] + 3600;
            }
            npeople++;
        }
    }
    printf("%.1f", total/60.0/(npeople/1.0));
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值