hdu3037 Saving Beans(Lucas定理+费马小定理or扩展欧几里德算发)

Saving Beans

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3221 Accepted Submission(s): 1234


Problem Description
Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.

Input
The first line contains one integer T, means the number of cases.

Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime.

Output
You should output the answer modulo p.

Sample Input
  
  
2 1 2 5 2 1 5

Sample Output
  
  
3 3
Hint
Hint For sample 1, squirrels will put no more than 2 beans in one tree. Since trees are different, we can label them as 1, 2 … and so on. The 3 ways are: put no beans, put 1 bean in tree 1 and put 2 beans in tree 1. For sample 2, the 3 ways are: put no beans, put 1 bean in tree 1 and put 1 bean in tree 2.

Source

题意: 不大于m颗种子存放在n颗树中,问有多少种存法(注意是不大于,并不是等于)。

分析:首先是不大于m颗种子,我没可以认为少于m的那些种子存放在了第n+1颗树上,这样的话,问题就转化成了将m颗种子存放在n+1颗树上的方案数。ok这个是组合数学里面的公式,亦即插板法,也就是X1+X2+X3+……+Xn+1 = m;so,答案是C(n+m,m)。然后就是基础的费马小定理求逆元(当然也可以用扩展欧几里德算法求逆元,然而我才刚开始学数论,并不会 - -),Lucas定理求解了。

费马小定理不懂的点这里

扩展欧几里德算法可以点这里

Lucas定理不懂的点这里


#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

ll f[100010];

ll init(ll p)//求阶乘,用于计算组合数
{
    f[0]=1;
    for (int i=1; i<=p ;i++)
        f[i] = f[i-1]*i%p;
}

ll mod_pow(int a, int n, int p)//这里求的是a^n,也就是(f[bb]*f[aa-bb]%p)^(p-2)
{
    ll aa = a,re = 1;
    while (n)
    {
        if (n&1) re=(re*aa)%p;
        aa=(aa*aa)%p;
        n>>=1;
    }
    return re;
}

ll Lucas(ll a, ll b, ll p)//Lucas定理
{
    ll re=1;
    while (a && b)
    {
        ll aa=a%p,bb=b%p;
        if (aa < bb) return 0;
        re =re*f[aa]*mod_pow(f[bb]*f[aa-bb]%p, p-2, p)%p;//费马小定理求逆元
        a /= p;
        b /= p;
    }
    return re;
}

int main ()
{
    int T;
    ll n,m,p;
    cin>>T;
    while (T--)
    {
        cin>>n>>m>>p;
        init(p);
        cout<<Lucas(n+m, m, p)<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值