hdu5512 Pagodas(2015ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学) )

Pagodas

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 14 Accepted Submission(s): 13


Problem Description
n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n . However, only two of them (labelled a and b , where 1abn ) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i{a,b} and 1in) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=jk . Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.

Input
The first line contains an integer t (1t500) which is the number of test cases.
For each test case, the first line provides the positive integer n (2n20000) and two different integers a and b .

Output
For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.

Sample Input
  
  
16 2 1 2 3 1 3 67 1 2 100 1 2 8 6 8 9 6 8 10 6 8 11 6 8 12 6 8 13 6 8 14 6 8 15 6 8 16 6 8 1314 6 8 1994 1 13 1994 7 12

Sample Output
  
  
Case #1: Iaka Case #2: Yuwgna Case #3: Yuwgna Case #4: Iaka Case #5: Iaka Case #6: Iaka Case #7: Yuwgna Case #8: Yuwgna Case #9: Iaka Case #10: Iaka Case #11: Yuwgna Case #12: Yuwgna Case #13: Iaka Case #14: Yuwgna Case #15: Iaka Case #16: Iaka

Source

题意:1到n个塔,Yuwgna和Iaka两人从a,b两点开始修建塔,每次可以修建塔的位置i=j+k或i=j-k;j和k为已修建好的塔的位置,Yuwgna开始修,最后谁不能修了谁就输了,问最后谁赢。
分析:最简单的签到题;首先判断a和b中有没有1,如果有的话,那么每个位置都能修建塔;如果没有,在判断a和b是不是互质,如果互质,那么肯定会出现1的情况,也就是1这位置总有一回合会修建塔,所以也是每个位置都能修建塔,然后就是不互质的情况了,不互质的话,可以修建塔的位置的个数就只有n/gcd(a, b);然后最后判断总共可以修建的塔的个数是奇数还是偶数就ok了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))

int main()
{
    int T,n,a,b;
    cin>>T;
    for(int cas=1; cas<=T; cas++)
    {
        cin>>n>>a>>b;
        if(b<a) swap(a, b);
        cout<<"Case #"<<cas<<": ";
        int t=__gcd(a, b);//a和b的最大公约数
        int cnt;
        if(a==1)//有1
            cnt=n;
        else
        {
            if(t!=1)//不互质
                cnt=n/t;
            else
                cnt=n;
        }
        if(cnt&1)
            cout<<"Yuwgna"<<endl;
        else
            cout<<"Iaka"<<endl;
    }
    return 0;
}


  
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值