hdu5540 Secrete Master Plan(The 2015 China Collegiate Programming Contest )

Secrete Master Plan

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 164 Accepted Submission(s): 116


Problem Description
Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, when Fei opened the pocket he found there are only four numbers written in dots on a piece of sheet. The numbers form 2×2 matrix, but Fei didn't know the correct direction to hold the sheet. What a pity!

Given two secrete master plans. The first one is the master's original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might give Fei the wrong pocket. Determine if Fei receives the right pocket.


Input
The first line of the input gives the number of test cases, T(1T104) . T test cases follow. Each test case contains 4 lines. Each line contains two integers ai0 and ai1 ( 1ai0,ai1100 ). The first two lines stands for the original plan, the 3rd and 4th line stands for the plan Fei opened.

Output
For each test case, output one line containing " Case #x: y", where x is the test case number
(starting from 1) and y is either "POSSIBLE" or "IMPOSSIBLE" (quotes for clarity).

Sample Input
  
  
4 1 2 3 4 1 2 3 4 1 2 3 4 3 1 4 2 1 2 3 4 3 2 4 1 1 2 3 4 4 3 2 1

Sample Output
  
  
Case #1: POSSIBLE Case #2: POSSIBLE Case #3: IMPOSSIBLE Case #4: POSSIBLE

Source

题意:就是看第一个2*2的矩阵能不能转成第二个矩阵。
分析:大大大大大大水题。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 100010

int main()
{
    int T;
    int a[4],b[4];
    cin>>T;
    for(int cas=1; cas<=T; cas++)
    {
        cin>>a[0]>>a[1]>>a[3]>>a[2];
        cin>>b[0]>>b[1]>>b[3]>>b[2];
        bool flag = false;
        for(int i=0; i<4; i++)
        {
            if(a[0]==b[0]&&a[1]==b[1]&&a[2]==b[2]&&a[3]==b[3])
                flag=true;
            else {int t=a[0];a[0]=a[1];a[1]=a[2];a[2]=a[3];a[3]=t;}
        }
        cout<<"Case #"<<cas<<": ";
        if(flag) cout<<"POSSIBLE"<<endl;
        else cout<<"IMPOSSIBLE"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值