poj3480 John (nim博弈变形--SJ定理)

John
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2940 Accepted: 1432

Description

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

Input

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

Output

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

Sample Input

2
3
3 5 1
1
1

Sample Output

John
Brother

Source


题意:在一般的nim博弈上稍作修改,就是最后取完的输,其他一样;

分析:这就牵扯到一个牛逼的定理了....SJ定理,然后就和基础nim一样了。

       我们提出定理里的两个限制:1、SG函数为不为0。2、有没有某单一游戏的SG函数大于1。

      通过这两个限制,我们可以组合出4种情况:

     (1)SG==0,有某单一游戏的SG>1。

     (2)SG!=0,有某单一游戏的SG>1。(必胜SJ)

     (3)SG==0,无某单一游戏的SG>1。(必胜SJ)

     (4)SG!=0,无某单一游戏的SG>1

 

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 1e9;
const int MOD = 1e9+7;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define lson (i<<1)
#define rson ((i<<1)|1)
#define N 50010
int gcd(int a,int b){return b?gcd(b,a%b):a;}

int main()
{
    int T,n,x;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int ans=0,cnt=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&x);
            ans ^= x;
            if(x > 1) cnt++;
        }
        if(ans==0)
        {
            if(cnt) cout<<"Brother"<<endl;
            else cout<<"John"<<endl;
        }
        else
        {
            if(cnt) cout<<"John"<<endl;
            else cout<<"Brother"<<endl;
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值