百练 / 2016计算机学科夏令营上机考试: E

题目来源:http://noi.openjudge.cn/ch0206/2421/

2421:Exchange Rates

总时间限制: 1000ms      内存限制: 65536kB

描述

Now that the Loonie is hovering about par with theGreenback, you have decided to use your $1000 entrance scholarship to engage incurrency speculation. So you gaze into a crystal ball which predicts theclosing exchange rate between Canadian and U.S. dollars for each of the nextseveral days. On any given day, you can switch all of your money from Canadianto U.S. dollars, or vice versa, at the prevailing exchange rate, less a 3%commission, less any fraction of a cent. 
Assuming your crystal ball is correct, what's the maximum amount of money youcan have, in Canadian dollars, when you're done? 

输入

The input contains a number of test cases, followed by aline containing 0. Each test case begins with 0 <d ≤ 365, thenumber of days that your crystal ball can predict. d lines follow, giving theprice of a U.S. dollar in Canadian dollars, as a real number.

输出

For each test case, output a line giving the maximumamount of money, in Canadian dollars and cents, that it is possible to have atthe end of the last prediction, assuming you may exchange money on any subsetof the predicted days, in order.

样例输入

3

1.0500

0.9300

0.9900

2

1.0500

1.1000

0

样例输出

1001.60

1000.00

-----------------------------------------------------

解题思路

动态规划,分别维护更新当前美元最大收益和当前加元最大收益。不用开数组,用4个变量就行。

两个坑点:

1. 计算中要用分为单位用int变量计算

2. 输出的时候要保留两位小数精度,例如这样就可以AC

ans0 = thecanada/100;

ans1 = thecanada%100;

printf("%d.%02d\n",ans0,ans1);

-----------------------------------------------------

代码

#include<stdlib.h>
#include<iostream>
#include<fstream>
#include<iomanip>
#include<stdio.h>
using namespace std;

int main()
{
    #ifndef ONLINE_JUDGE
    ifstream fin("xly2016E.txt");
    if (!fin)
    {
        exit(1);
    }
    int d = 0, i = 0;
    double therate = 0;
    int theusa = 0, thecanada = 0, n_usa = 0, n_canada = 0;
    int ans0 = 0, ans1 = 0;
    while (fin >> d)
    {
        if (d==0)
        {
            break;
        }
        thecanada = 1000*100;                               // 以“分”为单位
        theusa = 0;
        for (i=0; i<d; i++)
        {
            fin >> therate;
            n_usa = thecanada/therate*0.97;                   // 将第i-1天开始持有的加元换成美元
            theusa = n_usa>theusa? n_usa:theusa;              // 与继续持有第i-1天的美元比较取大者
            n_canada = theusa*therate*0.97;                   // 将第i-1天开始持有的美元换成加元
            thecanada = n_canada>thecanada? n_canada:thecanada;// 与继续持有第i-1天的加元比较取大者
        }
        ans0 = thecanada/100;
        ans1 = thecanada%100;
        printf("%d.%02d\n",ans0,ans1);
    }
    fin.close();
    #endif // LOCAL FILE
    #ifdef ONLINE_JUDGE
    int d = 0, i = 0;
    double therate = 0;
    int theusa = 0, thecanada = 0, n_usa = 0, n_canada = 0;
    int ans0 = 0, ans1 = 0;
    while (cin >> d)
    {
        if (d==0)
        {
            break;
        }
        thecanada = 1000*100;                               // 以“分”为单位
        theusa = 0;
        for (i=0; i<d; i++)
        {
            cin >> therate;
            n_usa = thecanada/therate*0.97;                   // 将第i-1天开始持有的加元换成美元
            theusa = n_usa>theusa? n_usa:theusa;              // 与继续持有第i-1天的美元比较取大者
            n_canada = theusa*therate*0.97;                   // 将第i-1天开始持有的美元换成加元
            thecanada = n_canada>thecanada? n_canada:thecanada;// 与继续持有第i-1天的加元比较取大者
        }
        ans0 = thecanada/100;
        ans1 = thecanada%100;
        printf("%d.%02d\n",ans0,ans1);
    }
    #endif // ONLINE_JUDGE
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值