2504: Exchange Rates

 


StatusIn/OutTIME LimitMEMORY LimitSubmit TimesSolved UsersJUDGE TYPE
stdin/stdout3s16384K20351Standard

Now that the Loonie is hovering about par with the Greenback, you have decided to use your $1000 entrance scholarship to engage in currency speculation. So you gaze into a crystal ball which predicts the closing exchange rate between Canadian and U.S. dollars for each of the next several days. On any given day, you can switch all of your money from Canadian to U.S. dollars, or vice versa, at the prevailing exchange rate, less a 3% commission, less any fraction of a cent. Assuming your crystal ball is correct, what's the maximum amount of money you can have, in Canadian dollars, when you're done?

Input

The input contains a number of test cases, followed by a line containing 0. Each test case begins with 0〈d ≤ 365, the number of days that your crystal ball can predict. d lines follow, giving the price of a U.S. dollar in Canadian dollars, as a real number.

Output

For each test case, output a line giving the maximum amount of money, in Canadian dollars and cents, that it is possible to have at the end of the last prediction, assuming you may exchange money on any subset of the predicted days, in order.

Sample Input

3
1.0500
0.9300
0.9900
2
1.0500
1.1000
0

Sample Output

1001.60
1000.00

 

Problem Source: Waterloo 9,23,2007

 


This problem is used for contest: 115 

 

#include<stdio.h>  //采用取百化整的方法
#include<string.h>
double rate[366];
int coin[366][2];
int main()
{
 //freopen("in.txt","r",stdin);
 //freopen("out.txt","w",stdout);
 int i,n,j;
 double k;
 while((scanf("%d",&n),n)!=0)
 {
  memset(coin,0,sizeof(coin));
  memset(rate,0,sizeof(rate));
  for(i=1;i<=n;i++)
      scanf("%lf",&rate[i]);
  coin[1][0]=1000/rate[1]*0.97*100;
  coin[1][1]=1000*100;
  for(i=2;i<=n;i++)
    for(j=1;j<n;j++)
    {
   if(coin[j][1]/rate[i]*0.97>coin[i][0])
          coin[i][0]=coin[j][1]/rate[i]*0.97;
   if(coin[j][0]*rate[i]*0.97>coin[i][1])
          coin[i][1]=coin[j][0]*rate[i]*0.97;
    }
  k=1000.00;
  for(i=1;i<=n;i++)
  if(coin[i][1]*1.0/100>k)
       k=coin[i][1]*1.0/100; 
  printf("%.2lf/n",k);
 }
 return 0;
}

 

以上是N^2的DP代码

 

以下是N的DP代码

我的DP还是不错的啊,哈哈!

 

#include<stdio.h>  //采用取百化整的方法
#include<string.h>
double rate[366];
int coin[366][2];
int main()
{
 //freopen("in.txt","r",stdin);
 //freopen("out.txt","w",stdout);
 int i,n;
 double k;
 while((scanf("%d",&n),n)!=0)
 {
  memset(coin,0,sizeof(coin));
  memset(rate,0,sizeof(rate));
  for(i=1;i<=n;i++)
      scanf("%lf",&rate[i]);
  coin[1][0]=1000/rate[1]*0.97*100;
  coin[1][1]=1000*100;
  for(i=2;i<=n;i++)
  {
   if(coin[i-1][1]/rate[i]*0.97>coin[i-1][0])
          coin[i][0]=coin[i-1][1]/rate[i]*0.97;
   else
          coin[i][0]=coin[i-1][0];
   if(coin[i-1][0]*rate[i]*0.97>coin[i-1][1])
          coin[i][1]=coin[i-1][0]*rate[i]*0.97;
   else
          coin[i][1]=coin[i-1][1]; 
  }
  k=0;
  for(i=1;i<=n;i++)
  if(coin[i][1]*1.0/100>k)
       k=coin[i][1]*1.0/100; 
  printf("%.2lf/n",k);
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值