HDU 2141 Can you find it? (二分)

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 505
int a[N], b[N], c[N], ab[N * N], x;
int la, lb, lc, lab, lx;
int main()
{
	int cnt = 0;
	while (~scanf("%d%d%d", &la, &lb, &lc))
	{
		cnt++; printf("Case %d:\n", cnt);
		for (int i = 1; i <= la; i++) scanf("%d", &a[i]);
		for (int i = 1; i <= lb; i++) scanf("%d", &b[i]);
		for (int i = 1; i <= lc; i++) scanf("%d", &c[i]);
		lab = 0;
		for (int i = 1; i <= la; i++)
			for (int j = 1; j <= lb; j++)
				ab[++lab] = a[i] + b[j];
		sort(ab + 1, ab + 1 + lab);
		lab = unique(ab + 1, ab + 1 + lab) - ab;
		scanf("%d", &lx);
		for (int i = 1; i <= lx; i++)
		{
			scanf("%d", &x);
			int j;
			for (j = 1; j <= lc; j++)
			{
				int key = x - c[j];
				if (*lower_bound(ab + 1, ab + 1 + lab, key) == key)	break;
			}
			if (j <= lc) printf("YES\n");
			else printf("NO\n");
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值