完美解决java compiler level does not match the version of the installed java project facet问题

    当Java项目更换电脑时会出现工程打岔的问题,但是项目中没有明显的语法错误,此时我们可以观察到输出工作区Problems选项中存在java compiler level does not match the version of the installed java project facet的问题,原因是java编译版本不匹配的问题


解决办法很简单,就是在本工程.settings文件夹中org.eclipse.wst.common.project.facet.core.xml文件中将版本改成与工程编译版本一直即可。

在Eclipse环境中,鼠标右键选择项目,点击Properties,选择Java Compiler,可以在窗口右边看到编译器版本:





阅读更多
文章标签: java
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

完美解决java compiler level does not match the version of the installed java project facet问题

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭