BobZhangfighting的博客

日复一日,年复一年,不要忘记当初的梦想

Tomact服务器报错:Java compiler level does not match the version of the installed java project facet

问题:


经常我们在导入别人的项目进入自己的工程时,会报Java compiler level does not match the version of the installed java project facet错误,那么怎么解决呢?

鄙人以为分为以下三步走:

首先在eclipse中,打开 window窗口====》preferences===》java===》compiler,然后会看到右边栏目有jdk compliance,把jdk版本号改为自己常用的版本:具体操作如下

再者在自己所导进工程的项目下右键====》properties====>java compiler;然后右边栏有一个Javacompiler版本,也改成jdk1.7,保持一样,具体如下图:

第三步:如上述两步还不能解决错误那么就执行第三步操作:

找到你所放项目的工作空间,打开项目,其中有一个.setting文件,具体操作如下:


相信完成以上三步刷新一下项目;那么错误也应该消失了。

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/BobZhangfighting/article/details/52254845
个人分类: 我的解决问题方法
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭