Description
It is said that 90% of frosh expect to be above average in their class. You are to provide a reality check.
Input
The first line of standard input contains an integer C, the number of test cases. C data sets follow. Each data set begins with an integer, N, the number of people in the class (1 <= N <= 1000). N integers follow, separated by spaces or newlines, each giving the final grade (an integer 0 <= final grade <= 100) of a student.
Output
For each case you are to output a line giving the percentage of students whose grade is above average, rounded to 3 decimal places.
Sample Input
5 5 50 50 70 80 100 7 100 95 90 80 70 60 50 3 70 90 80 3 70 90 81 9 100 99 98 97 96 95 94 93 91
Sample Output
40.000% 57.143% 33.333% 66.667% 55.556%
#include<iostream>
using namespace std;
int main()
{
int n,m,s[1001],i;
cin>>n;
while(n--)
{
int sum=0;
int avr=0;
int num=0;
cin>>m;
for(i=0;i<m;i++)
{
cin>>s[i];
sum+=s[i];
}
avr=sum/m;
for(i=0;i<m;i++)
{
if(s[i]>avr)
num++;
}
cout.setf(ios::fixed);
cout.precision(3);
cout<<(num*1.0/m*100)<<"%"<<endl;
}
}