Above Average
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 12394 | Accepted: 6553 |
Description
It is said that 90% of frosh expect to be above average in their class. You are to provide a reality check.
Input
The first line of standard input contains an integer C, the number of test cases. C data sets follow. Each data set begins with an integer, N, the number of people in the class (1 <= N <= 1000). N integers follow, separated by spaces or newlines, each giving the final grade (an integer between 0 and 100) of a student in the class.
Output
For each case you are to output a line giving the percentage of students whose grade is above average, rounded to 3 decimal places.
Sample Input
5 5 50 50 70 80 100 7 100 95 90 80 70 60 50 3 70 90 80 3 70 90 81 9 100 99 98 97 96 95 94 93 91
Sample Output
40.000% 57.143% 33.333% 66.667% 55.556%
Source
给N个数字,求这N个数字中,比平均值大的数字所占的百分比。
直接模拟。
注意点:
1)输出的时候不要以%.3lf输出,要以%.3f输出就可以。虽然无法解释,但是就记住吧(1WA)
2)输出百分号‘%’,使用“%%”输出。
3)结果需要四舍五入。
4)输出结果注意类型转换,使用(float)、(double)都可以(2AC验证)
5)(double)getnum / (double)n * 100和(double)getnum * 100 / (double)n都可以得到结果。(1AC验证)
代码(3AC 1WA):
#include <cstdio>
#include <cstdlib>
int arr[1100];
int main(void){
int ii, casenum;
int n, i, j;
double sum, ave;
int getnum;
scanf("%d", &casenum);
for (ii = 0; ii < casenum; ii++){
scanf("%d", &n);
for (i = sum = 0; i < n; i++){
scanf("%d", &arr[i]);
sum += arr[i];
}
ave = sum / n;
for (i = getnum = 0; i < n ; i++){
if (arr[i] > ave){
getnum++;
}
}
printf("%.3f%%\n", (float)getnum / (float)n * 100);
}
return 0;
}