hdu-1757-A Simple Math Problem(构造矩阵快速幂)

Lele now is thinking about a simple function f(x). 

If x < 10 f(x) = x. 
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10); 
And ai(0<=i<=9) can only be 0 or 1 . 

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m. 

Input

The problem contains mutiple test cases.Please process to the end of file. 
In each case, there will be two lines. 
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9. 

Output

For each case, output f(k) % m in one line.

Sample Input

10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0

Sample Output

45
104

思路:

 

代码:

    

import java.util.Arrays;
import java.util.Scanner;

public class main11 {
	static int k,m;
	static final int max=10;
	public static int[][] multi(int a[][],int b[][]){
		int res[][]=new int[max][max];
		for(int i=0;i<max;i++)
			Arrays.fill(res[i], 0);
		for(int i=0;i<max;i++)
			for(int j=0;j<max;j++)
		       for(int t=0;t<max;t++)
		    	   res[i][j]=(res[i][j]+a[i][t]*b[t][j]%m)%m;
		return res;
	}
	static final int[][] quick_pow(int a[][]){
		int res[][]=new int[max][max];
		for(int i=0;i<max;i++)
			for(int j=0;j<max;j++)
				if(i==j) res[i][j]=1;
				else res[i][j]=0;
		int b=k-9;
		while(b!=0){
			if((b&1)==1) res=multi(res,a);
			b/=2;
			a=multi(a,a);
		}
		return res;
	}
    public static void main(String[] args) {
		 Scanner scan=new Scanner(System.in);
		 while(scan.hasNext()){
		 k=scan.nextInt();
		 m=scan.nextInt();
	     int arr[]=new int[max];
	     for(int i=0;i<max;i++)
	    	 arr[i]=scan.nextInt();
	     if(k<10){
	    	 System.out.println(k);
	    	 continue;
	     }
		 int a[][]=new int[max][max];
		 for(int i=0;i<max;i++)
		     Arrays.fill(a[i], 0);
		 for(int i=0;i<10;i++)
               a[0][i]=arr[i];
		 for(int i=1;i<10;i++)
			 a[i][i-1]=1;
		 
		 int b[][]=new int[max][max];
		 b=quick_pow(a);
		 
		 int c[][]=new int[max][max];
		 for(int i=0;i<max;i++)
			 Arrays.fill(c[i], 0);
		 for(int i=0;i<10;i++)
			 c[i][0]=9-i;
		 
		 c=multi(b,c);
		 System.out.println(c[0][0]);
		 }

		 
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ksuper&

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值