A Simple Math Problem【矩阵快速幂】

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5673    Accepted Submission(s): 3470


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
 
 
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
 
 
45 104
 

Author
linle
 

Source
 

Recommend
lcy
 

思路:

建立矩阵递推式:

矩阵快速幂。


代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long long mod;
typedef long long LL;
struct state
{
    LL a[10][10];
};
state multi(state a,state b)
{
    state c={0};
    for(int i=0;i<10;i++)
    for(int j=0;j<10;j++)
    for(int k=0;k<10;k++)
    c.a[i][j]=(c.a[i][j]+(a.a[i][k]*b.a[k][j]))%mod;
    return c;
}
state quick_pow(state a,LL n)
{
    state b={0};
    for(int i=0;i<10;i++)
        b.a[i][i]=1;
    while(n)
    {
        if(n&1) b=multi(a,b);
        a=multi(a,a);
        n>>=1;
    }
    return b;
}
int main()
{

	LL n;
	while(~scanf("%lld%lld",&n,&mod))
    {
        state a={0},b={0};
        for(int i=0;i<10;i++)
            scanf("%lld",&a.a[0][i]);
        for(int i=1;i<10;i++)
            a.a[i][i-1]=1;
        for(int i=0;i<10;i++)
            b.a[i][0]=10-i-1;
        printf("%lld\n",multi(quick_pow(a,n),b).a[9][0]);
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值