1757 A Simple Math Problem

A Simple Math Problem

Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.

Output
For each case, output f(k) % m in one line.

Sample Input
10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0

Sample Output
45
104

#include<bits/stdc++.h>
using namespace std;
using LL=int64_t;
const int INF=0x3f3f3f3f;
int mod;
struct Node {
    LL m[12][12];
}sum,base;

Node muilt(Node a,Node b) {
    Node temp;
    for(int i=0;i<=9;i++) {
        for(int j=0;j<=9;j++) {
            temp.m[i][j]=0;
            for(int k=0;k<=9;k++) {
                temp.m[i][j]=(a.m[i][k]*b.m[k][j]+temp.m[i][j])%mod;
            }
        }
    }
    return temp;
}

LL q_mod(Node base,LL n) {
    memset(sum.m,0,sizeof(sum.m));
    for(int i=0;i<=9;i++)
        sum.m[i][i]=1;
    while(n) {
        if(n&1) sum=muilt(base,sum);
        n>>=1;
        base=muilt(base,base);
    }
    LL ans=0;
    for(int i=0;i<=9;i++)
        ans=(sum.m[0][i]*(9-i)+ans)%mod;
    return ans;
}

int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    LL k;
    while(cin>>k>>mod) {
        if(k<10) {
                cout<<k<<endl;
                continue;
        }
        memset(base.m,0,sizeof(base.m));
        for(int i=0;i<=9;i++)
                cin>>base.m[0][i];
        for(int i=1;i<=9;i++)
               base.m[i][i-1]=1;
        cout<<q_mod(base,k-9)<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值