完全背包

 

完全背包是指在所有物品件数无限多的情况下选择最值

问题一:

      有N种物品和一个容量为V的背包。第i种物品的体积是v,价值是w。求恰好装满背包时,求出最大价值总和是多少

题意:

输入

第一行: N 表示有多少组测试数据(N<7)。 
接下来每组测试数据的第一行有两个整数M,V。 M表示物品种类的数目,V表示背包的总容量。(0<M<=2000,0<V<=50000)
接下来的M行每行有两个整数c,w分别表示每种物品的重量和价值(0<c<100000,0<w<100000)

输出

对应每组测试数据输出结果(如果能恰好装满背包,输出装满背包时背包内物品的最大价值总和。 如果不能恰好装满背包,输出NO)

样例输入

2
1 5
2 2
2 5
2 2
5 1

样例输出                                      

              NO

             1

思路:

  背包体积为4时, 一种物品体积2,价值2;

  则   f[0]=0; f[1]=-max; f[2]=max(f[2],f[0]+w[i])=2; 注意若背包不需要全部装满时,f[3]本该为2的,但此时

  f[3]=max(f[3],f[1]+2)=max(f[3],2-max)=2-max; 负无穷

代码:

#include<iostream>
using namespace std;
int va[2005],w[2005];
int dp[50005]; 
#define Inf 0x3f3f3f3f
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int m,v;
		cin>>m>>v;
		for(int i=1;i<=v;i++)//dp初始化
		   dp[i]=-Inf;
		dp[0]=0;
		for(int i=0;i<m;i++)
		  cin>>w[i]>>va[i];
		for(int i=0;i<m;i++)
		   for(int j=w[i];j<=v;j++)//为了一步步判断是否在装满的情况下有最大值
		     dp[j]=max(dp[j],dp[j-w[i]]+va[i]);
		if(dp[v]<0) cout<<"NO"<<endl;
		else  cout<<dp[v]<<endl;
	 } 
	return 0;
 } 

 

 问题二:

       有N种物品和一个容量为V的背包。第i种物品的体积是v,价值是w。求恰好装满背包时,求出最小价值总和是多少

 

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36315    Accepted Submission(s): 18026


 

Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

 

 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

 

 

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

 

 

Sample Input

 

3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4

 

 

Sample Output

 

The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.

 

 

代码:

#include<iostream>
using namespace std;
int v[505],w[505],dp[10005];//重量为j时的最小价值 
#define Inf 0x3f3f3f3f
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int e,f,m,n;
		cin>>e>>f;
		m=f-e;//总重 
		for(int i=1;i<=m;i++)//dp初始化
		    dp[i]=Inf;
		dp[0]=0;
		cin>>n;
		for(int i=0;i<n;i++)
		   cin>>v[i]>>w[i];
		for(int i=0;i<n;i++)
		   for(int j=w[i];j<=m;j++)//是为了一步步判断在等于总重的情况下是否有最小值
		   {
		   	  dp[j]=min(dp[j],dp[j-w[i]]+v[i]);
		   }
		if(dp[m]!=Inf)
		  printf("The minimum amount of money in the piggy-bank is %d.\n",dp[m]);
		else
		  cout<<"This is impossible."<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小鱼爱吃火锅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值