zoj 1438 - Asteroids! 题解

Asteroids!

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Introduction

You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.


Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.


Output

For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.


Sample Input

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END


Sample Output

1 0
3 4
NO ROUTE


这个题不难也是,比较简单的搜索算法,用广度搜索,直接就找,不过是唯一一点新意就是,它是个三维的,然后自己得有空间想象能力就好,总之很easy。



但是,我提交的时候老师wa,后来才发现没看清题,题中是最多100个案例,而我把它当成就是一百个来处理,wa了n次,都不知道为啥,最后还是kp兄帮我看得,这里谢过了

。明显感觉到,输入输出自己能力还不行,特别是对字符串的处理能力很是薄弱。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std; 
typedef struct node{
    int col;
    int row;
    int slice;
    int floor;
    }node;
char path[10][10][10];
bool flag[10][10][10];
int N;
void PushAlladj(node temp,queue<node> &test){
    //左边界判断
    node next;
    int j=temp.col,i=temp.row,k=temp.slice; 
    if(j&&path[i][j-1][k]=='O'&&!flag[i][j-1][k]){
        next.col=j-1;
        next.row=i;
        next.slice=k;
        next.floor=temp.floor+1;
        test.push(next);
        flag[next.row][next.col][next.slice]=true;
        } 
    //右边界的判断
    if(j<N-1&&path[i][j+1][k]=='O'&&!flag[i][j+1][k]){
        next.col=j+1;
        next.row=i;
        next.slice=k;
        next.floor=temp.floor+1;
        test.push(next);
        flag[next.row][next.col][next.slice]=true;
        }
    //上边界的判断
     if(i&&path[i-1][j][k]=='O'&&!flag[i-1][j][k]){
        next.col=j;
        next.row=i-1;
        next.slice=k;
        next.floor=temp.floor+1;
        test.push(next);
        flag[next.row][next.col][next.slice]=true;
        }
     //下边界的判断
     if(i<N-1&&path[i+1][j][k]=='O'&&!flag[i+1][j][k]){
        next.col=j;
        next.row=i+1;
        next.slice=k;
        next.floor=temp.floor+1;
        test.push(next);
        flag[next.row][next.col][next.slice]=true;
        } 
        //顶层边界的判断
        if(k<N-1&&path[i][j][k+1]=='O'&&!flag[i][j][k+1]){
        next.col=j;
        next.row=i;
        next.slice=k+1;
        next.floor=temp.floor+1;
        test.push(next);
        flag[next.row][next.col][next.slice]=true;
        } 
        //底层边界的判断
        if(k&&path[i][j][k-1]=='O'&&!flag[i][j][k-1]){
        next.col=j;
        next.row=i;
        next.slice=k-1;
        next.floor=temp.floor+1;
        test.push(next);
        flag[next.row][next.col][next.slice]=true;
        } 
    }    
int main(){
    node org,tar,frontdata;
    int  i,j,k;
    char firstline[10];
    char lastline[5];
    int key;
    while(scanf("%s",firstline)!=EOF){
    queue<node>test;
    key=0; 
    scanf("%d",&N);
    getchar();
    for(k=0;k<N;k++){
       for(i=0;i<N;i++){
          for(j=0;j<N;j++){ 
             scanf("%c",&path[i][j][k]);
             flag[i][j][k]=false;
             } 
             getchar();    
             } 
          }    
    scanf("%d%d%d",&org.col,&org.row,&org.slice);
    scanf("%d%d%d",&tar.col,&tar.row,&tar.slice);
    scanf("%s",lastline);
    org.floor=0;//初始化工作 
    test.push(org);
    flag[org.row][org.col][org.slice]=true;
    while(!test.empty()){
        frontdata=test.front();
        if(frontdata.col==tar.col&&frontdata.row==tar.row
        &&frontdata.slice==tar.slice){
            test.pop();
            printf("%d %d\n",N,frontdata.floor);
            key=1;
        }
        else{//删除头结点并找到头结点所有邻接点把他们一一入队列,
            test.pop(); 
            PushAlladj(frontdata,test);
            } 
         }
         if(!key)printf("NO ROUTE\n");
        
       }//case--

        return 0;
        
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值