ZOJ 1438-Asteroids!(bfs入门题)

                                                      Asteroids!

Description

Introduction

You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.


Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.


Output

For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.


Sample Input

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END


Sample Output

1 0
3 4
NO ROUTE


题意:

   就是给出n层,n行,n列的一个地图给你,O是可走的路,X是不可走的路。输出n和最小的步数。


这题Wa了几次,竟然是在方向上写了一个相同的。。。。。。


AC代码:


#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<queue>
using namespace std;
#define T 110
struct node
{
	int x,y,z;
	int c;
	node(){}
	node(int _x,int _y,int _z,int _c)
		:x(_x),y(_y),z(_z),c(_c){}
}tar;

char str[T][T][T];
bool vis[T][T][T];

int fx[][3]={{0,1,0},{0,0,1},{0,-1,0},{0,0,-1},{1,0,0},{-1,0,0}};

int n;

bool judge(const node& t)
{
	if(t.x>=0&&t.x<n&&t.y>=0&&t.y<n&&t.z>=0&&t.z<n&&
		str[t.z][t.x][t.y]!='X'&&!vis[t.z][t.x][t.y])
	{
		return true;
	}
	return false;
}

int bfs(const node& t)
{
	memset(vis,false,sizeof(vis));
	queue<node> q;
	q.push(t);
	node p;
	int tx,ty,tz;
	while(!q.empty())
	{
		p = q.front();q.pop();
		if(p.x==tar.x&&p.y==tar.y&&p.z==tar.z){
					return p.c;
		}
		for(int i=0;i<6;++i){
			tz = p.z+fx[i][0];
			tx = p.x+fx[i][1];
			ty = p.y+fx[i][2];
			if(judge(node(tx,ty,tz,0))){
				vis[tz][tx][ty] = true;
				q.push(node(tx,ty,tz,p.c+1));
			}
		}
	}
	return -1;
}

int main()
{
#ifdef zsc
	freopen("input.txt","r",stdin);
#endif

	int m,i,j,k;
	char s[10];
	node p;
	while(~scanf("%s%d",&s,&n))
	{
		for(i=0;i<n;++i){
			for(j=0;j<n;++j){
				for(k=0;k<n;++k){
					scanf("\n%c",&str[i][j][k]);
				}
			}
		}
		scanf("%d%d%d",&i,&j,&k);
		p=node(j,i,k,0);
		scanf("%d%d%d",&i,&j,&k);
		tar = node(j,i,k,0);
		int tmp = bfs(p);
		if(tmp==-1){
			printf("NO ROUTE\n");
		}
		else {
			printf("%d %d\n",n,tmp);
		}
		scanf("%s",s);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值