Pat1005 Spell It Right

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10
​100
​​ ).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

题目思路:

  1. 读出一个字符串
  2. 分割转化为整型之后加起来求和
  3. 求和得到的数字转化为字符串分割开来
  4. 从往前一次去输出对应的单词
#include <iostream>

using namespace std;

int getchar(char c){
    int num = 0;
    num = c - '0';
    return num;
}

int main(){
    int sum = 0;
    string num;

    string Num[10] = {"zero","one","two","three","four","five","six","seven","eight","nine"};

    cin >> num;

    for(int i = 0;i < num.size();i++){
        sum += getchar(num[i]);
    }

    num = to_string(sum);

    cout << Num[num[0] - '0'];
    for(int i = 1;i < num.size(); i++){
        cout << ' ' <<  Num[num[i] - '0'];
    }

    return 0;
}

改良后的代码:

#include <iostream>

using namespace std;

int main()
{
    string n;
    cin >> n;

    int s = 0;
    for (auto c : n) s += c - '0';  // 可以用新语法来减少代码量 for (auto <item> : <items>){ ... }

    string str = to_string(s);

    char word[10][10] = {	//这个地方一开始使用的是switch来实现,用数组存放再用下标去找,是一种很巧的减少代码量的方法
        "zero", "one", "two", "three", "four",
        "five", "six", "seven", "eight", "nine",
    };

    cout << word[str[0] - '0'];//PAT的平台会区分句末空格,所以需要先把第一个输出,后面的再在前面拼上一个空格之后依次输出
    for (int i = 1; i < str.size(); i ++ ) cout << ' ' << word[str[i] - '0'];

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值