Pat1006 Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

题目思路:

  1. 因为所有的时间都有固定的格式,所以字典序排列即可
  2. 存放最早的人的id,最晚的人的id,最早和最晚的时间记录
  3. 针对输入的数据一一比对,选择满足时间要求的人替换id和最早/最晚时间记录
#include <iostream>

using namespace std;

int main(){
    int n;
    cin >> n;
    string arrive_id, leave_id , arrive_record = "99:99:99", leave_record = "00:00:00";
    for(int i = 0;i < n; i++){
        string id, arrive_time, leave_time;
        cin >> id >> arrive_time >> leave_time;
        if(arrive_time < arrive_record){
            arrive_record = arrive_time;
            arrive_id = id;
        }
        if(leave_time > leave_record){
            leave_record = leave_time;
            leave_id = id;
        }
    }
    cout << arrive_id << ' ' << leave_id;
    return 0;
}

代码改良:

#include <iostream>

using namespace std;

int main()
{
    string open_id, open_time;
    string close_id, close_time;

    int m;
    cin >> m;

    for (int i = 0; i < m; i ++ )
    {
        string id, in_time, out_time;
        cin >> id >> in_time >> out_time;
        
        if (!i || in_time < open_time)
        {
            open_id = id;
            open_time = in_time;
        }

        if (!i || out_time > close_time)
        {
            close_id = id;
            close_time = out_time;
        }
    }

    cout << open_id << ' ' << close_id << endl;

    return 0;
}

这代码我觉得其实没啥好改良的(小声逼逼)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值