PAT 1006 Sign In and Sign out

1006 Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意:在记录中查找开门的人和关门的人,也就是第一个进门最早的人和最晚出门的人

思路:这题还是比较简单的,稍微需要思考的是时间 HH:MM:SS 这样的,怎么表示时间和比较时间的大小就是这道题目的关键,可以直接将时间转化成数字,比如:21:31:23 -> 213123 这样的数字来存储,比较大小也方便(多刷题还是有用的!!!)

 代码:

#include <iostream>
using namespace std;

int main(){
    int n,e=0,l=0;//e表是开门人的下标,l表示锁门人的下标
    cin >> n;
    string name[n];
    int in[n],out[n];
    
    int h,m,s,t;
    for(int i=0;i<n;i++){
        cin >> name[i];
        scanf("%d:%d:%d",&h,&m,&s);
        t=h*10000+m*100+s;
        in[i]=t;
        e=in[e]<in[i]?e:i;
        scanf("%d:%d:%d",&h,&m,&s);
        t=h*10000+m*100+s;
        out[i]=t;
        l=out[l]>out[i]?l:i;
    }
    
    cout << name[e] << ' ' << name[l];
    
    return 0;
}

大佬的代码也很好,借鉴借鉴:

#include <iostream>
#include <climits>
using namespace std;
int main() {
    int n, minn = INT_MAX, maxn = INT_MIN;
    scanf("%d", &n);
    string unlocked, locked;
    for(int i = 0; i < n; i++) {
        string t;
        cin >> t;
        int h1, m1, s1, h2, m2, s2;
        scanf("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
        int tempIn = h1 * 3600 + m1 * 60 + s1;
        int tempOut = h2 * 3600 + m2 * 60 + s2;
        if (tempIn < minn) {
            minn = tempIn;
            unlocked = t;
        }
        if (tempOut > maxn) {
            maxn = tempOut;
            locked = t;
        }
    }
    cout << unlocked << " " << locked;
    return 0;
}

好好学习,天天向上!

我要考研!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值