Pat1035 Password

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:
3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
Sample Output 1:
2
Team000002 RLsp%dfa
Team000001 R@spodfa
Sample Input 2:
1
team110 abcdefg332
Sample Output 2:
There is 1 account and no account is modified
Sample Input 3:
2
team110 abcdefg222
team220 abcdefg333
Sample Output 3:
There are 2 accounts and no account is modified

题目思路:

  1. 记录总用户数量,修改的用户数量,密码字符串
  2. 密码字符串处理之后和原密码串比对,判断修改用户数量是否改变
  3. 按上述流程处理所有输入值
  4. 根据用户数量,修改数量来进行对应输出

(容易WA的点:输出的句子语法错误)

#include <iostream>
#include <vector>

using namespace std;

typedef struct account{
    string ID;
    string PWD;
};

string formatStr(string s){
    string res;
    int n = s.size();
    for(int i = 0;i < n;i++){
        if(s[n - 1 - i] == '1')
            res = '@' + res;
        else if(s[n - 1 - i] == '0')
            res = '%' + res;
        else if(s[n - 1 - i] == 'l')
            res = 'L' + res;
        else if(s[n - 1 - i] == 'O')
            res = 'o' + res;
        else{
            res = s[n - 1 - i] + res;
        }
    }
    return res;
}

int main(){
    int  m = 0,n = 0;//n = account num   m = modified num
    vector<account> accounts;

    cin >> n;
    for(int i = 0; i < n; i++){
        string id, pwd;
        cin >> id >> pwd;
        if(pwd != formatStr(pwd)){
            pwd = formatStr(pwd);
            m++;
            accounts.push_back({id, pwd});
        }
    }
    if(m == 0 && n == 1){
        printf("There is %d account and no account is modified",n);
    }
    else if(m == 0 && n > 1){
        printf("There are %d accounts and no account is modified",n);
    }
    else{
        cout << m << endl;
        for(int i = 0; i < accounts.size(); i++){
           cout << accounts[i].ID << ' ' << accounts[i].PWD << endl;
        }
    }
    return 0;
}

改良代码:

#include <iostream>

using namespace std;

const int N = 1010;

string name[N], pwd[N];

string change(string str)
{
    string res;

    for (auto c : str)
        if (c == '1') res += '@';
        else if (c == '0') res += '%';
        else if (c == 'l') res += 'L';
        else if (c == 'O') res += 'o';
        else res += c;

    return res;
}

int main()
{
    int n;
    cin >> n;

    int m = 0;
    for (int i = 0; i < n; i ++ )
    {
        string cur_name, cur_pwd;
        cin >> cur_name >> cur_pwd;
        string changed_pwd = change(cur_pwd);

        if (changed_pwd != cur_pwd)
        {
            name[m] = cur_name;
            pwd[m] = changed_pwd;
            m ++ ;
        }
    }

    if (!m)
    {
        if (n == 1) puts("There is 1 account and no account is modified");
        else printf("There are %d accounts and no account is modified\n", n);
    }
    else
    {
        cout << m << endl;
        for (int i = 0; i < m; i ++ ) cout << name[i] << ' ' << pwd[i] << endl;
    }

    return 0;
}

这个代码我感觉也差不多,没啥好改的- -

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值