HDU 1073 内容相等判断

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1073

Online Judge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7804    Accepted Submission(s): 2906


Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user's result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return "Accepted", else if the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge System should return "Presentation Error", else the system will return "Wrong Answer".

Given the data of correct output file and the data of user's result file, your task is to determine which result the Judge System will return.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user's result file. Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.
 

Output
For each test cases, you should output the the result Judge System should return.
 

Sample Input
  
  
4 START 1 + 2 = 3 END START 1+2=3 END START 1 + 2 = 3 END START 1 + 2 = 3 END START 1 + 2 = 3 END START 1 + 2 = 4 END START 1 + 2 = 3 END START 1 + 2 = 3 END
 

Sample Output
  
  
Presentation Error Presentation Error Wrong Answer Presentation Error
题解:此题我当时对结尾标志想了一会,第一反应用kmp 后来想想太麻烦,参考大神代码后,直接简单查询就可以,有的时候就是不用想太多。

代码如下:

#include<iostream>
using namespace std;
const int maxn = 5000;
char inputOrigal[maxn + 5];  //源文件
char inputNew[maxn + 5];     //用户文件
int lenOri = 0;//  源文件长度
int lenNew = 0;  //用户文件长度
bool judge(char str[],int n){       /*判断结尾标志  此处很巧妙   因为开头好处理,但是结尾不知道在哪*/
	if (str[n] == '\n'&&str[n - 1] == 'D'&&str[n - 2] == 'N'&&str[n - 3] == 'E'&&str[n - 4] == '\n') {
		return true;
	}
	return false;
}
bool judgeChar(char ch) {          /*判断空格 跳格 回车*/
	if (ch == ' ' || ch == '\t' || ch == '\n')
		return true;
	return false;
}
int main() {
	int numTest;
	cin >> numTest;
	while (numTest--) {
		char startTag[6];
		cin >> startTag;
		if (strcmp(startTag, "START") == 0) {   /*判断开头*/
			int indexOrigal = 0;
			getchar();
			while (1) {      /*存文件*/
				inputOrigal[indexOrigal] = getchar();
				if (judge(inputOrigal,indexOrigal)) {
					break;
				}
				indexOrigal++;
			}
			lenOri = indexOrigal - 4;/*记录文件长度 此处减去结尾标志*/
		}
		cin >> startTag;
		if (strcmp(startTag, "START") == 0) {
			int indexOrigal = 0;
			getchar();
			while (1) {
				inputNew[indexOrigal] = getchar();
				if (judge(inputNew,indexOrigal)) {
					break;
				}
				indexOrigal++;
			}
			lenNew = indexOrigal - 4;
		}
		bool accepet = true;    
		bool repretation = true;
		bool wrong = true;
		int oriFlag = 0, newFlag = 0;
		if (lenOri != lenNew)
			accepet = false;
		else {
			int i = 0;
			while (i < lenOri) {
				if (inputOrigal[i] != inputNew[i]) {
					accepet = false;
					break;
				}
				i++;
			}
		}
		while (1) {
			while (oriFlag < lenOri&&judgeChar(inputOrigal[oriFlag]))oriFlag++;
			while (newFlag < lenNew&&judgeChar(inputNew[newFlag]))newFlag++;
			if (oriFlag >= lenOri&&newFlag>=lenNew)
				break;
			else if (oriFlag >= lenOri || newFlag>=lenNew) {
				repretation = false;
				break;
			}
			else if (inputOrigal[oriFlag] != inputNew[newFlag]) {
				repretation = false;
				break;
			}
			else {
				oriFlag++;
				newFlag++;
			}

		}
		if (accepet)
			printf("Accepted\n");
		else if(repretation)
			printf("Presentation Error\n");
		else
			printf("Wrong Answer\n");
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值