A+B Coming

Description

Many classmates said to me that A+B is must needs. 
If you can’t AC this problem, you would invite me for night meal. ^_^ 
 

Input

Input may contain multiple test cases. Each case contains A and B in one line. 
A, B are hexadecimal number. 
Input terminates by EOF. 
 

Output

Output A+B in decimal number in one line.
 

Sample Input

    
    
1 9 A B a b
 

Sample Output

    
    
10 21 21
 

主要是strtol函数的运用,它可以将字符串里面的数字传换成10进制。

#include<stdio.h>
#include <stdlib.h>
int main(){
	char a[16],b[16];
	long long x,y,sum;
	while(scanf("%s%s",&a,&b)!=EOF){
	 x=strtol( a,NULL,16); 
     y=strtol( b, NULL,16); 
	 sum=x+y;
	 if(sum<0){
	 sum=-sum;
	 printf("-%d\n",sum);}
	 else 
	 printf("%d\n",sum);  
}}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值