杭电 HDU ACM 1720 A+B Coming



A+B Coming

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6464    Accepted Submission(s): 4248


Problem Description
Many classmates said to me that A+B is must needs.
If you can’t AC this problem, you would invite me for night meal. ^_^
 

Input
Input may contain multiple test cases. Each case contains A and B in one line.
A, B are hexadecimal number.
Input terminates by EOF.
 

Output
Output A+B in decimal number in one line.
 

Sample Input
  
  
1 9 A B a b
 

Sample Output
  
  
10 21 21
 
这个题无语……表示以前见过 但是忘了!!
知识一:
将十六进制转换为十进特例:
AB转换为dec;
0xAB
= 0x0A * 16 + 0x0B
= 10 * 16 + 11
= 171

c 输入十六进制和八进制方法:
scanf(“%x %x”,&a,&b);
scanf(“%o %o”,&a,&b);

c++ 方法:
cin>>hex>>a>>b;
cin>>oct>>a>>b;
输出与之类似 ,

败了 看来要请吃饭了!
AC:
#include<iostream>
using namespace std;
int main()
{
	int a,b;
	while(cin>>hex>>a>>b)
	  cout<<dec<<a+b<<endl;
return 0;
}


  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值