[PAT甲] 1051.Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the
摘要由CSDN通过智能技术生成

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:

YES
NO
NO
YES
NO


#include <iostream>
#include <vector>
#include <stack>

using namespace std;
int main() {
    int ca, len, num;
    cin >> ca >> len >> num;

    while (num--) {
        bool judge = false;
        vector<int> v(len);
        stack<int> s;
        for (int i = 0; i < len; ++i) {
            scanf("%d", &v[i]);
        }
        int index = 0;
        //模拟入栈
        for (int i = 1; i <= len; ++i) {
            s.push(i);
            if (s.size() > ca) break;
            while (!s.empty() && s.top() == v[index]) {
                s.pop();
                ++index;
            }
        }
        if (index == len) judge = true;
        judge == true ? cout << "YES" : cout << "NO";
        if (num) cout << "\n";
    }
    return 0;
}

这里的思想很重要,平时我们一般判断连续入栈的出栈顺序时候经常这样考虑。

  1. 单纯通过数字大小,比如,3217654就是非法的,因为,任意位置的后续比其小的数字必须降序排列。
  2. 模拟入栈出栈来判断,而这种情况是唯一一个不会有任何差错的操作,不过初次听到,似乎不知无从下手。

通过顺序入栈,,当然如果越界(如果此栈有界的话),就直接boom,如果此时栈顶和此时出栈queue一致就pop,然后移位下一位的queue,那么如果最终的位置在queue的尾后,就说明验证合法

for (int i = 1; i <= len; ++i) {
    s.push(i);
    if (s.size() > ca) break;
       while (!s.empty() && s.top() == v[index]) {
           s.pop();
           ++index;
       }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值