[PTA MOOC] 自测-4 Have Fun with Numbers(20 分)

自测-4 Have Fun with Numbers(20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798


#include <stdio.h>
#include <string.h>
//大数乘法
#define MAX 30
char num[MAX];
int res[MAX]={0};
//这里易错,要11位
char a1[11] = "0000000000";
char a2[11] = "0000000000";


int main() {
//方便输入
    scanf("%s", num);
    int len = strlen(num);
    int temp, carry = 0, index;
    for(int j=len-1, m=0; len>=0; --len, --j, ++m) {
    //这个分支保证可以最高位可以进位
        if(len==0) {
            temp = carry;
        }
        else {
            temp = (int)(num[j]-'0')*2 + carry;
        }
        res[m] = temp%10;
        carry = temp/10;
    }
    //去除前导0,得到index
    for(index=MAX-1; index>=0; --index) {
        if(res[index]!=0) break;
    }
    //下面两个循环比较,桶~~
    for(int i=0; i<strlen(num); ++i) {
        ++a1[(int)(num[i]-'0')];
    }
    for(int i=0; i<=index; ++i) {
        ++a2[res[i]];
    }
    //注意考虑0的情况
    if(strcmp(a1,a2)==0 || strcmp(num, "0")==0) 
        printf("Yes\n");
    else
        printf("No\n");

    if(strcmp(num, "0")==0) {
        printf("0");
    }
    else {
        while(index>=0) {
            printf("%d", res[index]);
            --index;
        }   
    }
    return 0;
}

最后说两句

我提莫,,,一样的代码,用c(clang)提交全错,我tm想了半天,抱着侥幸的想法用c(gcc)提交了一下,结果全对

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值