trie+dp

Neal is very curious about combinatorial problems, and now here comes a problem about words. Knowingthat Ray has a photographic memory and this may not trouble him, Neal gives it to Jiejie.Since Jiejie can’t remember numbers clearly, he just uses sticks to help himself. Allowing for Jiejie’sonly 20071027 sticks, he can only record the remainders of the numbers divided by total amount ofsticks.The problem is as follows: a word needs to be divided into small pieces in such a way that eachpiece is from some given set of words. Given a word and the set of words, Jiejie should calculate thenumber of ways the given word can be divided, using the words in the set.

Input

The input file contains multiple test cases. For each test case: the first line contains the given wordwhose length is no more than 300 000.The second line contains an integer S, 1 ≤ S ≤ 4000.Each of the following S lines contains one word from the set. Each word will be at most 100characters long. There will be no two identical words and all letters in the words will be lowercase.There is a blank line between consecutive test cases.You should proceed to the end of file.

Output

For each test case, output the number, as described above, from the task description modulo 20071027.

Sample Input

abcd

4

a

b

cd

ab

Sample Output

Case 1: 2


#define  MAX 26

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h> 
using namespace std;
 struct Trie
{
bool v; 
Trie *next[26];
void clear()
{
memset(next,0,sizeof next);
v=false;
}
}trie[400004];


char str[400004],tmp[104];
int n,tot,dp[400004];


void createTrie()
{
// int length = strlen(str);
Trie *p = &trie[0];
for(int i = 0;tmp[i];i++)
{
int id = tmp[i]-'a';
if(p->next[id] == NULL)
{
trie[tot].clear();
p->next[id] = &trie[tot++];
}

p = p->next[id];
}
p->v=true;
}
int l;
void  FindTrie(int add,int jmp)
{


Trie *p = &trie[0];
for(int i = jmp ;i<=l;i++)
{
if(p->next[str[i]-'a'])
{
p = p->next[str[i] - 'a'];
if(p->v)
dp[i]=(dp[i]+add)%20071027;
}
else
break;
}

}
int main()
{
int cas=1;
while(~scanf("%s",&str[1]))
{

scanf("%d",&n);
trie[0].clear();
tot=1;
for(int i=0;i<n;i++)
{
scanf("%s",tmp);
createTrie();
}
memset(dp,0,sizeof dp);
dp[0]=1;
l=strlen(&str[1]);
for(int i=1;i<=l;i++)
if(dp[i-1])
FindTrie(dp[i-1],i);

printf("Case %d: %d\n",cas++,dp[l]);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值