UVA-101 The Blocks Problem 栈

Description

Download as PDF

Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.

The Problem 

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are  n blocks on the table (numbered from 0 to  n -1) with block  b i  adjacent to block  b i+1  for all  $0 \leq i < n-1$  as shown in the diagram below:
 
\begin{figure}\centering\setlength{\unitlength}{0.0125in} %\begin{picture}(2......raisebox{0pt}[0pt][0pt]{$\bullet\bullet \bullet$ }}}\end{picture}\end{figure}
Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block aretain their order when moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.

  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

The Input 

The input begins with an integer  n  on a line by itself representing the number of blocks in the block world. You may assume that  0 <  n  < 25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output 

The output should consist of the final state of the blocks world. Each original block position numbered i ( $0 \leq i < n$ where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output 

 0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:
  
  
题目:给你n个方块,有四种操作:
1.move a onto b,把a和b上面的方块都放回原来位置,然后把a放到b上面;
2.move a over b,把a上面的放回原处,然后把a放在b所在的方块堆的上面;
3.pile a onto b,把b上面的放回原来位置,然后把a和a上面的方块整体放到b上面;
4.pile a over b,把a和a上面的方块整体放到b所在堆的上面。
定义两个基本操作: 
1.将a上面的还原init_place(a);
2.将a和上面的(可以没有上面的)放到b上面pile_a_to_b(a,b)。
那么上述的四组操作就变成下面了:
1.move a onto b,init_place(a);init_place(b);pile_a_to_b(a,b);
2.move a over b,init_place(a);pile_a_to_b(a,b);
3.pile a onto b,init_place(b);pile_a_to_b(a,b);
4.pile a over b,pile_a_to_b(a,b)。

#include<iostream>
#include<vector>
#include<cstdio> 
#include<stack>
#include<cstring>
using namespace std;
stack<int> vv[300];
int place[25],top[25],s[30][30]; 
void init_place(int a)//将a还原 
{
	int block=0,id=place[a];
	if(vv[id].empty())
	return ;
	
	//cout<<block<<endl;
	while(vv[id].top()!=a)
	{ //cout<<vv[id].top()<<endl;
		block=vv[id].top();
		place[block]=block;
		vv[block].push(block);//
		vv[id].pop();	
	}
	//cout<<vv[a].top()<<endl;
}
int temp[30];
void pile_a_to_b(int a,int b)
{
	int topt=-1,id=place[a],ID=place[b];
	while(vv[id].top()!=a)
	temp[++topt]=vv[id].top(),vv[id].pop();
	int x=vv[id].top();
//	printf(" %d\n",x);
	if(vv[id].top()==a)
	vv[id].pop();
	place[a]=ID;
	vv[ID].push(a);
	while(topt>=0)
	{
		place[temp[topt]]=ID;
		vv[ID].push(temp[topt--]);
	}
}
int main()
{
	int n,a,b;
	char op[6],type[6],x[30];
	 while ( ~scanf("%d",&n) ) {  
        for ( int i = 0 ; i < n ; ++ i ) {  
            vv[i].push(i) ;  
            place[i] = i;  
            //top[i] = 0;  
        } 
        while(~scanf("%s",op)&&op[0]!='q')
        {
        	scanf("%d%s%d",&a,type,&b);
        	if(place[a]==place[b])
        	continue;
        	if(op[0]=='m')
        	init_place(a);
        	if(type[1]=='n')
        	init_place(b);
        	pile_a_to_b(a,b);
        }
        memset(x,0,sizeof x); 
        	for(int i=0;i<n;i++)
        	{
        		printf("%d:",i);
        		int now=0,j=0;
        		while(!vv[i].empty())
        		{
        			
				 x[j++]=vv[i].top();
        		
				 vv[i].pop();
        		}
        		for(int i=j-1;i>=0;i--)
        		printf(" %d",x[i]);
        		puts("");
			}
		
	}
		return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值