POJ 3061 Subsequence 尺取法 POJ 3320 Jessica's Reading Problem map+set+尺取法

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13955 Accepted: 5896

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3


代码:

#include<iostream>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
using namespace std;
vector<int> ans;
int main() {
    int T;
    scanf("%d",&T);
    while(T--) {
        int n,m;
        scanf("%d %d",&n,&m);
        ans.clear();
        for(int i=0;i<n;++i) {
            int num;scanf("%d",&num);
            ans.push_back(num);
        }
        int s=0,t=0,sum=0,res=n+1;
        for(;;) {
            while(t<n&&sum<m) sum+=ans[t++];
            if(sum<m) break;
            res=min(res,t-s);
            sum-=ans[s++];
        }
        if(res>n) res=0;
        printf("%d\n",res);
    }
    return 0;
}
Jessica's Reading Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11931 Accepted: 4052

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line containsP non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

思路:可以采用尺取法来做,类似于第一题。从头开始,找到可以覆盖所有知识点的区间,再从左边一点点往回压缩。知识点不够的时候,再从右边开始探寻...重复此过程即可

代码:

#include<iostream>
#include<string>
#include<set>
#include<vector>
#include<map>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int main() {
    int p;
    while(~scanf("%d",&p)) {
        int number;
        vector<int> a;
        set<int> all;
        for(int i=0;i<p;++i) {
            scanf("%d",&number);
            a.push_back(number);
            all.insert(number);
        }
        int n=all.size();//一共有n个知识点
        int s=0,t=0,num=0;
        map<int,int> cnt;
        int res=p;
        for(;;) {
            while(t<p&&num<n) if(cnt[a[t++]]++==0) num++;
            if(num<n) break;
            res=min(res,t-s);
            if(--cnt[a[s++]]==0) num--;
        }
        printf("%d\n",res);
    }
    return 0;
}


转载于:https://www.cnblogs.com/lemonbiscuit/p/7775991.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值