HDU3792---Twin Prime Conjecture(树状数组)

Twin Prime Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2950    Accepted Submission(s): 1016


Problem Description
If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that "There are infinite consecutive primes differing by 2".
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.
 

Input
Your program must read test cases from standard input.
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.
 

Output
For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.
 

Sample Input
 
  
1 5 20 -2
 

Sample Output
 
  
0 1 4
 
题目大意:
题目的意思是,给定一个数字n。求小于n的孪生素数有多少对。孪生素数的概念就是说,相邻的两个素数之间差值为2。例如:5和7,17和19,这些都是。

解题思路:
先用筛法打了一个素数表,在素数表的基础上打出来一个直接保存结果的数组c[](树状数组直接处理的数组)。这样就可以直接用树状数组来解决了。基础的BIT应用。
如果不懂树状数组的话,可以去看这篇博客: 搞懂树状数组

源代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<deque>
#include<map>
#include<set>
#include<algorithm>
#include<string>
#include<iomanip>
#include<cstdlib>
#include<cmath>
#include<sstream>
#include<ctime>
using namespace std;

typedef long long ll;
#define MAXN 100005
int c[MAXN];//c[]从下标为1的地方开始

int lowbit(int x)
{
    return x&(-x);
}

void add(int x, int num)//x代表位置,num代表增量
{
    while(x<=MAXN)
    {
        c[x]+=num;
        x+=lowbit(x);
    }
}

int sum(int x)//代表求解1~x的和(x是下标)
{
    int res = 0;
    while(x>0)
    {
        res+=c[x];
        x-=lowbit(x);
    }
    return res;
}

int primer[MAXN];
int number[MAXN];

void init()
{
    memset(number,0,sizeof(number));
    int i,j;
    int cnt=0;
    for(i=2;i<=100000;i++)
    {
        if(number[i]==0)
        {
            cnt++;
            primer[cnt]=i;
            for(j=i*2;j<=100000;j+=i)
            {
                number[j]=1;
            }
        }
    }//素数表OK
    for(i=2;i<=cnt;i++)
    {
        if(primer[i]-primer[i-1]==2)
        {
            add(primer[i],1);//发现一对增加一个
        }
    }
}
int main()
{
    int n;
    init();
    while(scanf("%d",&n)!=EOF&&n>0)
    {
        printf("%d\n",sum(n));
    }
	return 0;
}




转载于:https://www.cnblogs.com/lemonbiscuit/p/7776086.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值