HDU_3792_(素数筛+树状数组)

Twin Prime Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3280    Accepted Submission(s): 1162


Problem Description
If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that "There are infinite consecutive primes differing by 2".
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.
 

 

Input
Your program must read test cases from standard input.
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.
 

 

Output
For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.
 

 

Sample Input
1
5
20
-2
 

 

Sample Output
0
1
4

题意:输入n,求小于n的孪生素数对有多少个。
 
素数筛+树状数组
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
#define N 100005

int s[N];
int prime[N],cntp;
bool isNot[N];

void getPrime()
{
    for(int i=2;i<=N;i++)
    {
        if(isNot[i]==0)
        {
            prime[cntp++]=i;
            for(int j=2;i*j<=N;j++)
                isNot[i*j]=1;
        }
    }
}
int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int num)
{
    while(x<=N)
    {
        s[x]+=num;
        x+=lowbit(x);
    }
}

int sum(int x)
{
    int res=0;
    while(x>0)
    {
        res+=s[x];
        x-=lowbit(x);
    }
    return res;
}

int main()
{
    cntp=1;
    getPrime();
    for(int i=2;i<cntp;i++)
        if(prime[i]-prime[i-1]==2)
            add(prime[i],1);
    int n;
    while(scanf("%d",&n)!=EOF&&n>0)
    {
        printf("%d\n",sum(n));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jasonlixuetao/p/6612376.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值