Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab programming contest abcd mnp
思路:最长公共子序列
动态规划
递推关系:
dp[i][j]= dp [i-1] [j-1] + 1 (si = tj 即两个字符相等) //在之前的位置上再+1
max( dp[i] [j-1], dp[i-1] [j]) (两个字符不等) // 在靠下一点的2个位置去最大值
Sample Output
4
2
0
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdio>
typedef long long ll;
#define N 5005
using namespace std;
int dp[N][N];
char a[N],b[N];
int main()
{
while(~scanf("%s%s",a,b)){
int la=strlen(a),lb=strlen(b);
for(int i=0;i<la;i++)
dp[i][0]=0; //0列初始化
for(int i=0;i<lb;i++)
dp[0][i]=0; //0行初始化
for(int i=1;i<=la;i++)
for(int j=1;j<=lb;j++)
{
if(a[i-1]==b[j-1])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=max(dp[i][j-1],dp[i-1][j]);
}
printf("%d\n",dp[la][lb]);
}
return 0;
}
本题目对数组清0的时候有一定的限制,用memset造成内存超限,本片段那个数组大小是根据输入的字符串决定的,可能不大,而memset赋初值0下那种方式是固定的5005×5005,应该是超出范围了