HDU1503 Advanced Fruits (最长公共子序列)

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn 't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR ), and there is no shorter string that has the same property. 


A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 


Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters. 


Input is terminated by end of file. 
Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable. 
Sample Input
apple peach
ananas banana
pear peach
Sample Output
appleach
bananas

pearch

题意:将两个字符串结合起来,他们的公共子串只输出一次

思路:根据LCS的原理,将每个字符都进行标记,看两个字符串中对应的字符究竟处于什么状态,然后输出,其标记为公共子串的字符只输出一次即可。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdio>
typedef long long ll;
#define N 1005
using namespace std;
char s1[N],s2[N];
int len1,len2,dp[N][N],vis[N][N];
void PrintLCS(int i,int j)
{
    if(i==0&&j==0) return;
    if(vis[i][j]==0)
    {
        PrintLCS(i-1,j-1);
        printf("%c",s1[i-1]);
    }
     else if(vis[i][j]==1)//根据回溯的位置进行输出
    {
        PrintLCS(i-1,j);
        printf("%c",s1[i-1]);
    }
    else
    {
        PrintLCS(i,j-1);
        printf("%c",s2[j-1]);
    }
}
int main()
{
    while(~scanf("%s%s",s1,s2))
    {
        len1=strlen(s1);
        len2=strlen(s2);
        memset(dp,0,sizeof(dp));
        for(int i=0; i<=len1; i++)
            vis[i][0]=1;
        for(int i=0; i<=len2; i++)
            vis[0][i]=-1;
        for(int i=1; i<=len1; i++)
            for(int j=1; j<=len2; j++)
            {
                if(s1[i-1]==s2[j-1])
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                    vis[i][j]=0;
                }
                else if(dp[i-1][j]>=dp[i][j-1])
                {
                    dp[i][j]=dp[i-1][j];
                    vis[i][j]=1;
                }
                else
                {
                    dp[i][j]=dp[i][j-1];
                    vis[i][j]=-1;
                }
            }
        PrintLCS(len1,len2);
        printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值