最长公共子序列(2)--hdu1503(能力题)

Advanced Fruits

                                         Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.

Input

Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.

Output

For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.

Sample Input

apple peach
ananas banana
pear peach

Sample Output

appleach
bananas
pearch

         这道题的题意给你两个单词,然后你要把两个单词拼接成一个新单词,使得新单词的子序列中包含两个单词,

并且要使这个新单词最短。就是将两个字符串结合起来,他们的公共子序列(并非连续)只输出一次,

例如第一个例子:apple与peach的公共子序列为pe,两个字符串剩下的部分按原来的位置顺序输出,可能会有多个

结果,只需输出任一个就ok,比如最后一个例子pear与peach输出peachr也是可以的。


思路:根据LCS的原理,将每个字符都进行标记,看两个字符串中对应的字符究竟处于什么状态,然后输出,其标记为公共子串的字符只输出一次即可,也是一道模板题了。


上面说的字符处于什么状态就是说需要增加二维数组mark记录状态转移路径:(a与b代表两个字符串),mark的i,j是从0~n,a与b的i和j是从0~n-1:


mark[i][j] = 0 表示mark[i][j]由mark[i-1][j-1]转移过来,即a[i-1]与b[j-1]属于最长公共子序列中的元素;
mark[i][j] = 1 表示mark[i][j]由mark[i-1][j]转移过来,即a[i-1]不属于最长公共子序列中的元素;
mark[i][j] = -1 表示[i][j]由mark[i][j-1]转移过来,即b[j-1]不属于最长公共子序列中的元素。

注意输出的时候是用递归根据回溯的位置进行输出。上个图吧,直观一些:


        刚才那个mark标记就是记下在dp的过程中到底是从左边继承的(j-1)还是从上边基继承的(i-1),还是从斜上方继承(i-1,j-1).那么代码中,mark初始化时,第一排的只能是从左边继承的,所以mark[0][i]都初始化为-1,同理第一列(mark[i][0])都初始化为1。说的这么详细,应该ok了吧!上代码:

#include<stdio.h>
#include<string.h>
char str1[105];
char str2[105];
int vis[105];
int dp[105][105];
int mark[105][105];
int len1,len2;
void LCS(){
	int i,j;
	memset(dp,0,sizeof(dp));
	for(i=0;i<=len1;i++){
		mark[0][i]=-1;        //初始化很重要,想想为什么这么初始化
	}
	for(i=0;i<=len2;i++){
		mark[i][0]=1;
	}
	for(i=1;i<=len1;i++){
		for(j=1;j<=len2;j++){
			if(str1[i-1]==str2[j-1]){
				dp[i][j]=dp[i-1][j-1]+1;
				mark[i][j]=0;          //标记路径
			}
			else if(dp[i-1][j]>=dp[i][j-1]){
				dp[i][j]=dp[i-1][j];
				mark[i][j]=1;          //标记路径
			}
			else {
				dp[i][j]=dp[i][j-1];
				mark[i][j]=-1;         //标记路径
			}
		}
	}
}
void Print(int i,int j){    //根据回溯的位置递归地进行输出
	if(!i&&!j){
		return;
	}
	if(mark[i][j]==0){   
		Print(i-1,j-1);
		printf("%c",str1[i-1]);
	}
	else if(mark[i][j]==1){
		Print(i-1,j);
		printf("%c",str1[i-1]);
	}
	else {
		Print(i,j-1);
		printf("%c",str2[j-1]);
	}
}
int main()
{
	while(scanf("%s%s",str1,str2)!=EOF){
		len1=strlen(str1);
		len2=strlen(str2);
		LCS();
		Print(len1,len2);
		printf("\n");
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值