HDU - 3466 Proud Merchants (01背包的变形 + 贪心)

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi. 
If he had M units of money, what’s the maximum value iSea could get? 


Input
There are several test cases in the input. 


Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money. 
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.


The input terminates by end of file marker. 


Output
For each test case, output one integer, indicating maximum value iSea could get. 


Sample Input
2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3
Sample Output
5

11

题意:N个物品,M金钱,接下来的N行为物品的   价格    需要你至少有多钱才卖给你    价值 ,求用M金钱可以得到的最大价值的物品。

思路:0-1背包的变形,此题目添加了一个限制的条件,至少有Qi钱才卖给你,购买方式是  应该先买M最大的物体(M=Q-P),然后依次买第二大、第三大,所以此时根据0-1背包的性质按照M从小到大进行(

for (int j = v; j >= w[i]; -- j)

        dp[j] = max(dp[j - w[i]] + v[i], dp[j]);

(0-1背包的性质是逆序,所以我们是从小到大的排序,然后第一个被处理的是最大的那个)

#include <iostream>
#include <cstdio>
#include <map>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <set>
using namespace std;
const int N = 505;
int dp[5005];
struct node
{
    int w;
    int q;
    int v;
    int p;
}a[N];
bool cmp(node a,node b)
{
    return a.p<b.p;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)==2){
     for(int i=1;i<=n;i++){
        scanf("%d%d%d",&a[i].w,&a[i].q,&a[i].v);
        a[i].p=a[i].q-a[i].w;
     }
     sort(a+1,a+1+n,cmp);
     memset(dp,0,sizeof(dp));
     for(int i=1;i<=n;i++)
        for(int j=m;j>=a[i].q;j--)
        dp[j]=max(dp[j],dp[j-a[i].w]+a[i].v);
       printf("%d\n",dp[m]);
    }
    return 0;

}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值