杭电-1016Prime Ring Problem(素数打表+DFS)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36162    Accepted Submission(s): 15945


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 


这是个深搜,求出小于给定数 的所有素数环

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int result[25],m,used[25];
bool is_prim(int x)
{
	int i;
	if(x==1)
	return false;
	for(i=2;i<=floor(sqrt(x)+0.5);i++)
	{
		if(x%i==0) 
		return false;
	}
	return true;
}
void dfs(int n)
{
	int i;
	if(n>m&&is_prim(result[n-1]+1))
	{
		for(i=1;i<n-1;i++)
		printf("%d ",result[i]);
		printf("%d\n",result[n-1]);
		return ;
	}
	else{
		for(i=1;i<=m;i++)
		{
			if(is_prim(i+result[n-1])&&!used[i])
			{
				result[n]=i;
				used[i]=1;
				dfs(n+1);
				used[i]=0;
			}
		}
	}
}
int main()
{
	int cot=1;
	while(scanf("%d",&m)!=EOF)
	{
		memset(used,0,sizeof(used));
		memset(result,0,sizeof(result));
		result[1]=1;
		used[1]=1;
		printf("Case %d:\n",cot++);
		dfs(2);
		printf("\n");
	}
	return 0;
 } 




另外,我get一项新技能,素数打表!



void is_prim()
{
    memset(prim,0,sizeof(prim));
    prim[0]=prim[1]=1;
    int sq=sqrt((double)40);
    for(int i=2;i<sq;i++)
        for(int j=i*i;j<40;j+=i)
            prim[j]=1;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值