Prime Ring Problem(DFS)

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
题意:给出一个数n,求1到n是否能构成一个素数环,即一个环内任意相邻的两个数之和为素数;
思路:简单的DFS,先用素数删选法来判别是否为素数,然后DFS递归判断;
代码:

#include<stdio.h>
#include<string.h>
int t;
int b[21],a[100];
int mark[21];
void init()
{
    memset(a,0,sizeof(a));
    for(int i=2;i<=100;i++)
    {
        if(!a[i])
           for(int j=i;j<=100;j+=i)
              a[j]=i;
    }
}
void dfs(int n,int s)
{
    if(s-1==t&&a[n+1]==n+1)
    {
        printf("1");
        for(int i=2;i<=t;i++)
           printf(" %d",b[i]);
        printf("\n");
    }
    if(s-1>=t)
       return;
    for(int j=2;j<=t;j++)
    {
        if(!mark[j]&&a[n+j]==n+j)
        {
            mark[j]=1;
            b[s]=j;
            s++;
            dfs(j,s);
            s--;
            mark[j]=0;
        }
    }
}
int main()
{
    int T=1;
    init();
    while(~scanf("%d",&t))
    {
        printf("Case %d:\n",T++);
        memset(b,0,sizeof(b));
        memset(mark,0,sizeof(mark));
        dfs(1,2);
        printf("\n");
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值