1886: Phone List
Description
Given a list of phone numbers, determine if it is consistent in thesense that no number is the prefix of another. Let’s say the phonecatalogue listed these numbers:
- Emergency 911
- Alice 97 625 999
- Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central woulddirect your call to the emergency line as soon as you had dialled thefirst three digits of Bob’s phone number. So this list would not beconsistent.
Input
The first line of input gives a single integer, 1<=t<=40, the number of test cases. Eachtest case starts with n, the number of phone numbers, on a separate line, 1<=n<=10000.Then follows n lines with one unique phone number on each line. A phone number is asequence of at most ten digits.
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
Sample Input
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
Sample Output
NO YES
解题思路:题目很水,只要排一次序就可以了。。。然后逐一比较就可以了。。。
代码如下:
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
struct P{
char s[101];
}a[10001];
bool cmp(P a,P b)///排序
{
if(strcmp(a.s,b.s)>0) return false;
else return true;
}
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%s",&a[i].s);
sort(a,a+n,cmp);
int f=0;
for(int i=0;i<n;i++)
{
if(strncmp(a[i].s,a[i+1].s,strlen(a[i].s))==0)
{f=1; break;}
}
if(f) printf("NO\n");
else printf("YES\n");
}
return 0;
}