[HDU1000] A + B Problem

Problem Description

 

Calculate A + B.

 

Input

 

Each line will contain two integers A and B. Process to end of file.

 

Output

 

For each case, output A + B in one line.

 

Sample Input

 

1 1

 

Sample Output

 

2

 

分析

输入两个数A和B,求A+B。

 

但是是多行的,因此需要用循环反复读取。

 

又因为输入数据中没有说有多少行,因此不能使用计数循环,而要通过while循环判断是否到达文件尾,如果是则停止循环。

 

而在循环中则是将输入的两个数的和算出,并输出。

 

因此C/C++代码如下:

 

C

 

#include <stdio.h>
int main()
{
    int a, b;
    while (scanf("%d%d", &a, &b) != EOF)
        printf("%d\n", a + b);
    return 0;
}

 

C++

 

C++和C区别不大,仅仅是<stdio.h>和<iostream>,printf和cout,scanf和cin,以及如何判断EOF。

 

#include <iostream>
int main()
{
    int a, b;
    while (cin >> a >> b)
        cout << (a + b) << endl;
    return 0;
}

 

转载于:https://www.cnblogs.com/collectionne/p/6786367.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值