PAT (Advanced Level) Practice

#PAT (Advanced Level) Practice

Time:2021.5.15 

1001 A+B Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where − 1 0 6 10^6 106≤a,b≤ 1 0 6 10^6 106.The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

// 1001

#include<iostream>
#include<vector>
using namespace std;

int main(){
   
    int a,b;
    int sum;
    cin>>a>>b;
    sum = a + b;

    if(sum == 0){
   
        cout<<0; //输出int型

    }

    if(sum < 0){
   
        cout<<"-";
        sum *= -1;
    }
    //-9997
    vector<int> v;
    while(sum != 0){
   
        v.emplace_back(sum%10); //7999
        sum /= 10;


    }
    //9,997从高位输入 9
    for(int i = v.size()-1; i>=0; i--){
   
        cout<<v[i];
        if
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

羊老羊

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值