02-线性结构4 Pop Sequence

 

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

翻译:给定一个最多能保存M个数的堆栈。按1,2,3,…,N的顺序推N个数字,然后随机弹出。您应该知道给定的数字序列是否可能是堆栈的弹出序列。例如,如果M是5,N是7,我们可以从堆栈中获得1,2,3,4,5,6,7,但不能从3,2,1,7,5,6,4。

输入规格:

每个输入文件包含一个测试用例。对于每种情况,第一行包含3个数字(都不超过1000):M(堆栈的最大容量)、N(推送序列的长度)和K(要检查的pop序列的数量)。接下来是K行,每行包含N个数字的pop序列。一行中的所有数字都用空格隔开。

输出规格:

对于每个弹出序列,如果确实是堆栈的可能弹出序列,则在一行中打印“是”,如果不是,则打印“否”。
 

 

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

这道题题意缕了好久才知道是啥意思,总的来说就是 

需要模拟一下堆栈的出入栈的过程,进而来判断Pop序列是否是可能的。

这里有一个手绘的图解 对应第二个样例

  

 

#include <iostream>
#include <vector>
#define Maxsize 1000//最大容量
using namespace std;

struct Node {
    int Top;    //Top记录的是堆栈顶元素的位置
    int Array[Maxsize];
    int Size;
};

typedef struct Node* Stack;

bool check(vector<int> array,int m,int n)  //得知道堆栈有多大m,要判断的序列有多大n
{
    Stack s;
    s = new struct Node;
    int count = 0;
    s->Size = m;
    s->Top = -1;
    for (int i = 1; i <= n; i++)
    {
        if (s->Top + 1 == s->Size) return false;   //堆栈满
        else  s->Array[++s->Top] = i;
        while (s->Array[s->Top] == array[count])
        {
            s->Top--;  //出栈
            count++; //数组往后移
        }
        //cout<<count<<endl;
    }
    if (count  == n) return true;
    else return false;
}

int main()
{
    int M, N, K;    //M栈  N序列 K组数
    cin >> M >> N >> K;
    vector<int> Arry;
    int a;
    for (int i = 0; i < K; i++)
    {
    	Arry.clear();
        for (int j = 0; j < N; j++)
        {
            cin >> a;
            Arry.push_back(a);
        }
        if (check(Arry, M, N)) cout << "YES" << endl;
        else cout << "NO" << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值